Fedora 14 - Asus Motherboard - PS2 lockups Solved

Addendum: Somewhere along the line during one of the Fedora upgrades this blacklist file got saved off to an rpmsave file and the asus_ast0110 is happily being loaded with no ill effects. So I guess this issue has been fixed somwhere along the line.

Ever since installing FC14 on a ASUS P7P55D-E Pro system I was plagued with PS2 lockups. The only fix I was able to come up with was to bypass PS2 altogether and go with USB keyboard and mouse. Which worked fine but OTOH, things should just work, right?

Well finally the answer is in. Thanks to Bob P on the Fedora Forums as well as others such as Brad and Josh on the Ubuntu forums the problem seems to be related to a driver conflict between the PS2 driver and the asus_atk0110 driver which apparently has something to do with fans and fan speeds.

For Ubuntu this is bug #632048 which is a duplicate of bug #557065. The fix (or the workaround) is to blacklist the asus_atk0110 driver by simply editing the file /etc/modprobe.d/blacklist.conf and adding the single line

                         blacklist asus_atk0110
Post a Comment

Popular posts from this blog

Hit failing alternator with a hammer to confirm diagnosis of failing alternator due to bad brushes

alternatives --install gets stuck: failed to read link: No such file or directory

Fedora 23 Calendar PopDown in DarkGlass Gnome Shell Theme is cut off